Ubuntu Linux install problem

So I’m trying to switch my Linux machine from Fedora 4 to Ubuntu 6.06 (Dapper Drake). I stick the disc in (the x64 version, because I’m running an Athlon 64 3000+ in that machine), and it begins to load its drivers and mount drives and yadda yadda yadda. Right when it should go to the GUI, it cuts to a blue-and-red DOS style screen that says that the X session has been terminated. When I look through the detailed error log, I see that it loaded all drivers perfectly fine (including my Radeon X800 PCIe) but when it tries to initialize the video card to start the GUI, it says that the card can’t be started because of a PCI conflict with a non-video PCI peripheral. The only other thing plugged into a PCI slot on the computer is a wlan card (which is one of the reasons why I want to switch to Ubuntu, because Fedora’s a big bitch when it comes to wlans and I heard Ubuntu isn’t). There are no devices in the other PCIe slot.

Any suggestions? I’m about to try the x86 version (once it finishes downloading) to see if I have any better luck, but I’m not exactly expecting it.


Tried the x86 version; it crashed in the same place, but kicked me to a terminal prompt before I could view the log file. Does anyone have any ideas as to how to fix this, or, barring that, another build of Linux that plays friendly with wlan cards without the whole ndiswrapper crap? I tried ndiswrapper some 20 or so times in Fedora to no avail. I hear ndiswrapper is pre-built in to Ubuntu, and requires very little configuring, which is why I was interested.

Try and boot in safe graphics mode or switch the x-drivers to vesa. You can do that in /etc/X11/xorg.conf. I have the same problem on my laptop. Haven’t really bothered to try and fix it though.

If you’re not afraid to get your hands dirty, OpenBSD is supposed to have excellent WLAN support.

Installing in safe graphics mode worked for the x86 version, but not the x64 version. Oh well, it’s running. What’s more, I was able to get the wlan up and running with the excellent tutorials on the Ubuntu wiki site. The only things I still have to do are configure the mouse for 5 buttons (which I did every time I installed Fedora, so that’s nothing new to me) and some how find a way for my Radeon X800 to work in Ubuntu so I can use some resolution other than 1024x768 (which is giant on my 21" monitor, and gives me no room to view programs). Any advice on the video card issue?


Already fixed the mouse issue, which, as I assumed, didn’t take long.

BTW, while we’re on the subject of Ubuntu, the Synaptic Package Manager has officially made me its bitch. I will never again speak “praises” of Windows, if I was ever accused of doing such a thing, until they have something to even remotely rival this. Period.

You could try and install the official drivers. Who knows? They might work for a change.

Synaptic holds nothing to the console and Aptitude!

Well, the official driver didn’t take my resolution up as high as I wanted (1680x1050) but it at least got me to 1280x768, which will have to do for now. Also, I was able to apt-get a copy of VisualBoyAdvance, so I can go back to playing games on this machine. Now I guess I should try to get my X360 controller to work in Linux. :smiley:

Thanks for the help, nul.