I asked for help before but didn’t get any so I am going to try again…I am playing Sword of Mana and I am stuck in Wendell Cave.You are supposed to move forward and jump up a ledge.I have tried everything to get ontot he ledge but nothing works.I have pressed L,I have pressed and A at the same time,I have tried this with all 3 weapons.Meanwhile,the game gathers dust as I cannot jump this stupid ledge.Can anyone tell me exactly how to do this?I really need explicit directions.PLEASE help me… :hyperven: Snes verison GBA verison

I don’t know if the gba verison differs any and sorry can’t help you out more I haven’t played the game much myself. Hope the links on the pages can help or if they don’t you can search google or some other search engine using the words: walkthrough, Sword of mana, and Wendell cave.

It’s not a remake of Secret of Mana, it’s a remake of Final Fantasy Adventure (Seiken Dentsu) for the Game Boy.

Dude, the cactus thing in the desert tottaly had me stumped for like, 3 months. I finally just went online to figure it out. Then the game was a breeze because I spent those 3 months killing those four wolf guys up on some ledge somewhere. Then the game was so easy that I just stopped playing it.

I’ve been to GAME FAQS…it was my first stop.It wasn’t helpful.Can anyone give me explicit directions so I don’t have to trade this game in?I really like it and want to finish it… :scream:

I tried looking this up, but I can’t find a place called Wendel Cave. I know the name Wendel from FFA, but I didn’t find a cave associated with it. Do you mean the Marsh Cave?