Help configuring my machine to install something in Japanese.

I’ve been trying to install the Tsukihime game and found out that I’m obviously missing some key piece of software. I’m in Win98, by the way.

The problem is that when my machine is supposed to show supposedly Japanese text on the installation windows, it shows a bunch of junk characters instead, which seem to be a trouble when creating files. This has happened before on other cases, such as torrent files with Japanese characters being replaced by junk text and not installing. Overall, it seems the machine doesn’t recognise the text as valid and cannot create the correct paths.

To exemplify, this is what I look at after pressing install:

After which I’m asked to assign a folder:

And I get what I imagine must be some error message and the whole process is cancelled:

I think I must be missing a function or something. The possibility of a corrupt file is low, because once again, this has happened before, my machine is just incapable of displaying Japanese on menu options.

You need to enable Japanese/East Asian language support, it’s pretty simple to do in XP, but I really have no clue as for 98. That’s what you should be looking for if you’re trying to find help documents at least.

All I’ve found was Microsoft’s GlobalIME Japanese Language Pack, which I have had installed for a long while, but all it does is allow me to view normal text in Japanese, not the text in program windows. Once again, for example:

I can see the common highlightable text fine, but the bar up there is still fucked up. Could it be that 98 simply has no such option?

Your computer can display IME without having it actually installed. If you want to use IME for <i>programs</i> and not just viewing text, this is how i do it. The only downside is that you’ll have to see the stupid language bar all the time (but i guess you’re used to that since you probably have a non-english keyboard).

  • Go to control panel and open up “Regional and Language Options”
  • Click on “Languages” tab
  • Click the checkbox “Install languages for East Asian blah blah”
  • Click apply
  • You might need to restart
  • Get back to “Regional and Language Options” if you restarted
  • Click on “Advanced” tab
  • Under “Code Conversion Table” check japanese, Big5Chinese, and any other east asian fonts you might think you need. Probably korean too.
  • Might need to reboot again
  • Back in advanced, select “Japanese” in the drop down menu for “Support for non-UNICODE programs”
  • Might need to reboot yet again
  • Click the “languages” tab, and then the “details” checkbox
  • You should see a window that says “Text Input Services”
  • Next to “Installed services” click “add”
  • Input Language: Japanese / Keyboard layout: Japanese
  • Click ok
  • You’re done. You should be able to view japanese text in Explorer, and anything else part of the windows shell now. You can also select “JP” on the language bar to type japanese text using roman keyboards (handy for pretending like you know japanese 可愛い!!~)

EDIT: Hmm, you’re using Win98…i only have XP, but see if this will work on 98 also.

It doesn’t, you’d have to buy and use the Japanese version of Windows 98.

Just as I thought. I can access a whole lot of languages from the regional configurations, but non of them are Asian or otherwise non-roman-alphabet languages. Oh well, another incentive to buy a new machine as soon as possible I guess. Thanks anyway.