FF7 Glitch / Bug

Okay, so I searched the internet and didn’t find any information about this one, so I thought I’d share it with the (somehow still) rabid FF7 community, but I don’t know where they hide, so I thought I’d post it somewhere familiar to me, and hope you guys can pass it forward.

Okay, so, perhaps the strangest part of this story is the fact that I was replaying FFVII. Well, it’s been 10 years, and I thought I’d give it another chance. I’m finding myself enjoying it more this time than I remember, so maybe I won’t knock it as much in the future. MAYBE.

Anyway, so I’ve gotten as far as fighting Emerald and Ruby WEAPON. Ruby went down no problem. Emerald gave me a little trouble, but I seemed to get him on the second try. “Seemed to” being the operative words there. I didn’t bother to equip the Underwater Materia (didn’t want to forget to unequip it later), so I was running against the timer. I managed to fell him with 7 seconds left on the clock. Apparently, that’s not enough time. The clock struck 00:00 right as the screen faded to the EXP screen. The “Game Over” music started to play (ON TOP of the victory fanfare), and the words “Game Over” appeared in a text window at the top, as if I’d been killed. This was OVER the experience/AP screen. The screen started jumping sporadically between the EXP/AP and Game Over screens. When I pressed Circle to go on to the Items/Gil screen, it started jumping between a black screen, and the proper screen. Then, it played the proper Underwater/Submarine music, but the screen jumped back and forth between the New Game / Continue screen, and the view of me sailing the submarine around. When I hit circle, I got to the Select File screen, but the underwater music was still playing. I hit circle again, and my save file loaded up, from before I beat Emerald WEAPON. There was some artifacting on the character portraits in the menu screen, but everything else seemed fine. Then I tried to fight Emerald again…

The attached screen shots show what happened. If I selected any attacks/commands, nothing happened. If I followed the games instructions, I’d leave the battle, and Emerald would be floating somewhere else. If I ran into him again, the same thing would happen. If I fought any other battles, again, same thing.

For conditions to try to recreate the glitch:

  • Everyone had Master Summon and Master Command. Hadn’t gotten the Shield Materia yet, so no Master Magics.
  • I WAS playing on an emulator… yeah, that’s why the screen shots are so crisp. Sorry, I didn’t want to dig out a PS1 memory card just to replay 7.
  • I was also using the original FFVII discs. The same one’s I bought in 1997. Still in pretty good shape, too.

Anyway, I don’t know if it’s that important or not, but as I’ve been replaying the game, I’ve been checking out FF7 information online, and the fanbase seems to be quite excitable even to this day, and there are fairly exhaustive lists of glitches and bugs. I just didn’t see this on eon any of them, and I thought I’d share it with you guys.

(I have higher resolution versions of these pictures [1280x720], but since the PS1 only output at 320x240, I went ahead and shrunk 'em… also for space)

I have never heard of this one before, but if I were to look up information about it I’d look up information on beating Emerald Weapon without the Underwater Materia since it may be a side effect of the fight not taking into consideration that you could beat Emerald in under 20 mins (if not you may have accidentally stumbled onto something there).

Also what emulator are you using since there is the possibility of the emulator having something to do with it.

If you were playing on PC I dunno if this is a legit bug… but it’s still cool.

What are you asking though? Do you want to fix it or something? You’d probably be good just re-killing him.

FFVII is totally awesome. Who DOESN’T replay it once every couple years? I need to find myself a copy now.

I don’t replay it… what with all the sequels and other games that feature FF7 characters (KH, Dissidia) I still get my fill. 8p I’m still holding out for a remake.

It’s not the same playing some patchwork game like KH or Dissidia. I need the real thing. I don’t even consider AC or anything like that to be “canon.” It’s too retarded.

I just didn’t care for FFVII compared to the earlier (and some later) games in the series. I dunno. I just don’t like the characters that much.

Anyway, I wasn’t asking for help fixing it or anything. I just went back and fought him again (beat him in 13 1/2 minutes this time, still no Underwater materia), no problem. I just wanted to share with the FF7 fanbase, because I know there must be a few “definitive” bug lists out there… I just don’t know how to find them. So, now this is on the internet. Other people who have the problem can no that they’re not alone.

I went through FFVII a few years back (like 07 or something) and it felt kinda bland to me. It did not feel to me like it aged well at all.

Yeah… IMO FF6 has aged a lot better than FF7. FF7’s translation was rough, and the graphics are cringe-worthy. I honestly think it looks worse than FF6 does. Hence why I’m holding out for a remake. :sunglasses:

Actually I was referring more to the horribly uneven pacing of the game.

After leaving Midgar you find yourself in the middle of a JRPG with a flashback that never ends staring you in the face, followed by a port town with another port town above it (this one’s modern though), which is followed by a trip to a Mediterranean resort, and then the rest of the first disk is comprised almost entirely of character development leaping from one character to the next (sans Aerith, Yuffie, and Vincent). In fact the entire second continent feels like it was inspired by Disney World’s ‘It’s a small world after all!’ ride.

And then there’s the second disk which is mostly comprised of fetching huge materia, chasing the ghosts out from Cloud’s mental closet, snowboarding, and parachuting into Midgar (not entirely in that particular order).

FF VIII had similar problems of keeping all of it’s locales in the same technological age, but at least it had the pacing to put all the high-tech stuff at the end instead of jumping back and forth between resorts and trash heaps like VII did.

I can honestly say none of that ever bothered me. It gave some variety to the settings.