EPSXE problems

so im was playing final fantasy nine and i made it to that big sand storm place and when ever i walk into it and then go inside the first building it just goes black and stays that way

if this has happened to anybody while playing and iso on espxe do you think you could help me?

I’m not quite sure what is causing the problem, but it sounds like the disc could be damaged or dirty. Can you move your characters around still or does the game freeze? I once had a game that kept on freezing at exactly the same part of the game so that could be the problem.

im playing on an iso, so i downloaded it .not a cd

and when ever i go into this one place while the screen goes black it just stays black

only at this one part, i have a save state right before and i can go any but there and i have to get there

it also didn’t work when i loaded my game oFf my save file, not save state, and went there

i fixed it.
all i did was switch to an earlier version of EPSXE and copy and pasted all my memcards. i loaded my game and played back up to that part and it worked fine.