Boss change in U.S. version of Secret of Mana

I have noticed that some members list this as their favorite game- There is a boss in the Super Famicom version of this game called Seiken Densetsu 2 that was changed for the U.S. Super Nintendo version called Secret of Mana.
In the underground city in Secret of Mana there is a boss called the Kettle Kin which is a robot holding 2 hammers that attacks your party. In the Super Famicom version of the game that same boss is this bad looking dude with a chainsaw that spins around and tries to cut your party to pieces- The sound effect of the buzzing chainsaw is really good.
I made a video tape playing both games on my Super Nintendo connected to my VCR with both bosses if any member who really likes this game would like to see the Chainsaw boss.i would be happy to send a video tape of both bosses to anyone who requests it.
i also played Estpolis 2 (Lufia II) and made a video tape of the submarine shrine area where you find Dual Blade and the sinistral Daos taunts you for not being able to use it. The entire area including Dual Blade and Daos are visible in the super famicom version of the game but the graphics are totally screwed up in Lufia II as anyone who has played this game knows.

Would it be possible for you to post a screenshot of the chainsaw-bot? It sounds cool.

The Lufia 2 shrine is also normal in the German version, and I’d assume it is in every PAL version.

The JP version of Lufia II (Estpolis II) that I’ve played has the submarine shrine all messed up. Same with the 100th floor of the bonus dungeon. I had always heard that only the EU/PAL versions had that fixed.

I was playing the game on my super nintendo with a converter when i made the video of the chainsaw boss- the only way i can take a picture of the boss is to play the game on my ZSNES emulator which allows you to take screen pictures- i am just starting the game on the emulator- when i get to the boss i will take a pic and post it here.
As to Lufia II my super famicom version called Estpolis II has the submarine shrine graphics ok.If the european version also has this area ok then i downloaded a ROM version with a (U) in the name- Lufia II (U). This should be a european version and if i play the game up to the shrine the graphics should be ok.

That’s really odd that your copy of Estpolis II isn’t all glitchy in the Submarine Shrine. The only JP copy I ever had access to (which belonged to a friend who has a much more massive game collection than me) produced the same effects as the US version at that point.

(edit) just re-read your post. Lufia II (U) is the US/Canada version. You’re looking for E (England or Europe? I’ve never known…), F (French), G (German), or H (Hungary? Holland? There’s another one that’s always stumped me…). If possible, check for one with a [!] at the end of it, that signifies that it’s a verified good dump.

E is Europe (UK is United Kingdom, so it wouldn’t be England).

I don’t think there IS an H (except lowercase ‘h’, which means “hack”). It can’t be Holland, since NL is Netherlands, and there’s nothing for Hungary that I’m aware of.

So Kilroy had chainsaw instead of hammers? cool

I found a (E) [!] ROM of lufia 2 - i am going to play that one to see if the submarine shrine is screwed up- and i made a video tape of the Japanese Estpolis II showing the submarine shrine and i will send it to you if you want to see it.I noticed there are some chests in the upper right hand corner of the U.S. version.Those chests aren’t there in the Japanese version-
As far as i know those chests in the U.S. version are not accessable.I have tried to manuver my way around that screwed up graphics area to reach them but i can’t . Has anyone else been able to reach those chests and what is in them?

If you use the Jewel Sonar in the shrine, it doesn’t ring. So I assume that there’s nothing there and the chests are just a graphical error.

Yeah, the chests are just there because of the glitchiness, and it puts the chest tile on those tiles. There’s no actual chests.

I played through Estpolis 2 once. I sent a map I made of the shrine to Sinistral, and it was posted on the Lufia 2 shrine.
Also, I believe there’s a few ROMs of Estpolis 2 out there. I had a 4MB ROM that wouldn’t do anything, a 3MB ROM that worked, but would crash an old version of ZSNES that I was using, and a 2MB ROM that I used to finish the game. So, the 2MB ROM should be the correct dump of Estpolis. (2.5 for Lufia 2-US).
Also, a side question: were the capsule monsters broken in the PAL versions?
The US version made the capsule monsters request some one-time equipment that is only found near the end of the game (and Dragon Eggs :eek: ), whereas in the Japanese version, they made MUCH more reasonal requests (stuff you could easily buy in shops).
The only way I got the monsters in L2US was to exploit the fact that Level 1 monsters’ cravings are set to Long Knife (a cheap weapon found pretty early in the game) every time you reset the game.

Psh, there’s a better way. The War Rapier trick. If you feed a monster a War Rapier and then some random item (I like to use Shrieks, they’re the cheapest) several times, it’ll start craving War Rapier again. You can do so as many times as you want to get the monster to Class 4.

In the German version, the Capsule monsters were generally much more reasonable about what they were fed.

Hey, just a thing with the capsule monsters… you know how you feed them the opposite element fruit to get them to M class? It’s never worked for me, and I’ve done it on all levels, all requirements I’ve ever found for them.