belkin usb adapter in ubuntu with ndiswrapper


this has been going on a few weeks, so lots of updates.

i had issues w this before on this old comp & got them resolved by following this post:…9&postcount=22

now i switched to cable & have to either use the belkin on the new comp or move this thing to living room.

i tried to re do what i did before but 2 problems:

the green light on the belkin only comes on for part of boot up time then turns off.
i can’t find BLKWGU.sys anywhere on the belkin cd. it just has an .inf one, and the BLKWGUxp,2k,or 9x.sys files.

last night i downloaded this stuff again thinking i could find a BLKWGU.sys in there but i didn’t. i didn’t so i tried w32n55.ini only to see it not work. i don’t understand why it says blkwu.inf driver installed hardware present when nothing works…

gail@badassness:~$ sudo ndiswrapper -l
Installed drivers:
blkwgu		  driver installed, hardware present 
blkwgu2k.sys	invalid driver!	  invalid driver!
blkwgu.sys	  invalid driver!
blkwguxp.sys	invalid driver!
w32n55.ini	  invalid driver!
gail@badassness:~$ sudo ndiswrapper -e
Usage: ndiswrapper OPTION

Manage ndis drivers for ndiswrapper.
-i inffile		Install driver described by 'inffile'
-d devid driver   Use installed 'driver' for 'devid'
-e driver		 Remove 'driver'
-l				List installed drivers
-m				Write configuration for modprobe
-da			   Write module alias configuration for all devices
-di			   Write module install configuration for all devices
-v				Report version information

where 'devid' is either PCIID or USBID of the form XXXX:XXXX
gail@badassness:~$ sudo ndiswrapper -e blkwgu2k
Driver blkwgu2k is not installed.Use -l to list installed drivers
gail@badassness:~$ sudo ndiswrapper -e blkwgu2k.sys
gail@badassness:~$ sudo ndiswrapper -e blkwguxp.sys
gail@badassness:~$ sudo ndiswrapper -e blkwgu.sys
gail@badassness:~$ sudo ndiswrapper -e
gail@badassness:~$ sudo ndiswrapper -e w32n55.ini
gail@badassness:~$ sudo ndiswrapper -l
Installed drivers:
blkwgu		  driver installed, hardware present 

i tried every file in there except hte driver.xx files. here’s what’s in there from memory:


when i do sudo ndiswrapper -l i see

blkwgu hardware present, driver installed.

the other files i try off the cd all say

(name) invalid driver.

i now have a wired connection for htat computer so i tried to un/reinstall the drivers & ndiswrapper, and start all over. i still get the same results: nothing working.

i installed network-manager-gnome & disabled the connections in system>networking and that didn’t make a difference either.

the only thing i can think of to make it work is to get to a windows computer & download fresh ones from the belkin site & see if i can find a blkwgu.sys

today i tried re installing the ndiswrapper-utils & -common from synaptic & using the blkwgu.inf from the other computer and again from the belkin cd, neither of them work.

i tried downloading belkin’s v3 & 4 drivers & installing them to different folders on a friend’s windows (vista) computer & looking in there for more inf & sys files, nothing there to work off of.

i tried screwing w network-manager-gnome & it says it connects to i_like_baked_beans but i can’t get out anywhere. the only way i can get this computer on the net is my 50 ft network cable. the signal light on the adapter still turns off @ boot time. i think i typed sudo modprobe ndiswrapper in my sleep.

so what am i missing here?

i thought maybe something’s wrong w ndiswrapper:

gail@badassness:~$ ndiswrapper -v
utils Error: no version specified!
driver version:		1.22
vermagic:	   2.6.17-11-generic SMP mod_unload 586 REGPARM gcc-4.1

but reinstalling doesn’t seem to make a difference.

i’ve tried getting this working w/o having ethernet plugged in, and that makes no difference either. i have ndiswrapper on the list of mods to load up @ boot time. i think its /etc/modules or something. i’ve tried turning wep off, tried connecting thru different wep keys,


wireless don’t work cuz either i am missing a file, i can’t get the right ndiswrapper version, or i still have to learn how to configure a router… ;( i need a :beer_mug: :beer_mug: :beer_mug: :beer_mug:
help i’ve tried everything! even turning off the interfaces in system>networking & relying on network-manager.

if there’s any other info needed let me know & i’ll post here. right now i <3 my long cable…


actually it’s more like learn to post when i’m awake :stuck_out_tongue:
so aside from that, got any ideas?

hi, i’m italian,
you can send me the files:


becaus i have lost my CD

thank you!