I just got X-wing for 5 bucks the other day, and I’m having problems

It says I don’t have enough EMS memory to run it, and I should convert some memory I have into EMS memory.

This sounds like a lot of work

Any ideas on how else I could run this?

Did you try a dos emulator?


Now thats a damn old game.

  1. Download the application i have attached. It will check to see if you have EMS enabled.

  2. Run this application. If it says 16777216, or anything far higher than 0x0 next to “Bytes EMS total” then you have EMS. Go to step A. If it says 0x0, or something low and close to that, or says nothing at all about EMS, you do not have EMS memory enabled at all, and need to enable EMS memory.

Go to Step A if EMS memory is listed by the application i gave you, but the program still does not run.

Go to Step B if no EMS is listed.

Go to Step C if you did step B and still no EMS is listed.


Right click the file (possible extensions are .batch .exe or .pif) that launches the game. It might have a MSDOS logo. Go to Properties > Memory. If you have a input box here for EMS memory, increase it. See if the game works by increasing it.

If not, also try adding a /R flag at the end of the cmd line under the program tab. (ie: C:\whatever\whatever\imhot\sex\game.exe /R). This will force the program to fill EMS memory and nothing else.


Open notepad. Open the file C:\WINDOWS(or winnt)\System32\Config.nt (warning, its a system file).

With it open, look (search) for the line “files=40”

Change 40 to 60

If it doesn’t have such a line, add it at THE VERY BOTTOM.

Run memtest program i gave you again. If STILL no EMS is shown, add this line to the VERY BOTTOM of config.nt


Make sure there is a blank line (press enter) after the last line in config.nt if you add anything to the bottom.

Run memtest again and hope it works. If you still have no EMS, well then go to step C.

Step C

Ok, if you tried B and it didn’t work, you may have upgraded from an odd windows copy. Because the windows version is odd, we’ll have to force EMS memory through a different system file.

Open notepad

Find Autoexec.nt (again, ultra important sys file, be careful), it is in C:\WINDOWS (or winnt)\System32.

Look for this:

REM ***************************
REM ** Lines below this have been migrated from the original Microsoft ME settings
REM ****************************

Ok. If it looks like what is above, and THERE IS NO REM IN FRONT OF “SET COMSPEC” then add the 3 letters REM to the front of set comspec so it looks like:


Save this file.

Reboot your PC and pray you didn’t make a brick.

Run memtest.

Yes it is a dell

ok i edited my post after i said that. read my post, i hope it makes sense, i’m really tired and the stuff i’m suggesting is mostly crazy crap that makes sense in my head, but might not to you.

trying to help though D: i’ll re-read in the morning and edit again to make it more readable.

Jez, that’s really nice of you! I’ll try this tommarow when I’m not tired.

How’d you get so good with computers anyway?

If you get it to work and like it, I highly HIGHLY reccomend you try Tie Fighter.

Uh, just use dosbox. If you use the D-Fend front end for it, it’s rather simple to change the amount of memory it allocates. You don’t actually need to have actual EMS memory, the emulator handles that for you. I wouldn’t do what dev suggested until you fiddle around with the emulator settings (as he said, you could make a brick out of your machine, and for what cost, surely playing a really old game isn’t worth scrapping your PC), and D-Fend makes it easy to do.

Goddamn you Epic. If he did that, it would be too easy!

Actually, yea, try what epic said first. I didn’t even know that such a program/emulator existed. XD

I edited my post making it easier to follow.

That’s one thing that I’ve always found annoying about using XP, (or ME?). It totally scraps good ol’ DOS, so you basically can’t play older games… like Stunts! Stunts kicks so much arse!
Thanks loads for that guys! - been trying to figure it for a while…


P.S: (Linux still r0x0rs!)

Dos Box works! Thanks guyz!

Just aking, but what was the dos emulator you were using before?