Problems running WC3...

Yesterday, I trid to run WC3 (Frozen Throne). It locked up, and I have to restart my computer. I figured it was a fluke. I tried it again. My computer locked up AGAIN. Today I cleaned the disk and tried to run it again. Three guesses what happened. >.<;

I don’t get any error messages or anything. It just tries to run WC3 and then…locks up. I can’t cancel, I can’t Ctrl-Alt-Del…nothin’. ANY idea what can cause this?

Try the following:

Use the Uninstall feature to completely remove the game from your hard drive.
Reinstall the game
Go to and download the latest patch for the game and patch it

If this doesnt work, there may be some screwed up error on your disc, thus you’ll need to get a fixed exe that prevents the game from detecting the CD when you try to run the game, so you can go to (mods, this is legal please don’t block it) and get the “fixed exe” for the version you are patched to.

That is all I know to try, if the problem persists… post a help request on the Blizzard forums.

The blizz forums are useless, don’t even try going there.

Anyway, I hope you fix your problem, Mr. Good Game Crono Four :confused:

get more RAM
I was haing the same problem with WC3, but my comp could barely run the game anyway, so I didn’t worry. I upgraded over the summer, and it runs like a dream.

Up until now, I never had any problems running the game. And yes, I know the Blizzard forums ain’t worth crap. All they do is whine about how over/underpowered everything is.

I’ll try un/reinstalling it (after I back up a righteous number of maps) as soon as I get my RoC disc back (lent it to my cousin). Thanks for the help, guys.

Actually kor, the tech support forums in the blizz site Helped me a ton when I had some troubles with wc3, maybe you just went to the wrong forum. :stuck_out_tongue:

But yeah, try what Izlude says, and if that doesn’t work, then post about it in the tech support forum.

Okay, here’s what’s what.

I un and reinstalled, and manually downloaded the patch. But I still encounter the same problem. I DO, however, have a bit more clarity on said problem.

What messes up is the “Launching WarCraft 3” thingy that appears on start up. When I installed the patch, the Launching screen didn’t appear, and it went right into WC3. From there, everything ran fine. I think I might have to take this to BNet tech help, but if anyone else has an idea of what’s up, please say so.

And it’s not a problem with the disc. I had the same problem when I tried to run Frozen Throne off my RoC disc.

Were not saying that there is a problem with the disc, but rather the program may be having a coding problem with recognizing the disc in your cd drive. Perhaps your drivers are out of date? Who knows, either way, the “no-cd” crack is just an alternate version of the EXE that launches the game WITHOUT checking for a CD in the drive. It’s a life saver when you have as many games as I do and dont want to have to dig through all your shit to find the CD.

I will give that a shot. Thank you…I’ll let you know how it works out.

EDIT: Yay, it works. Thanks.