Damn You, Computer!

Okay, so I happened to tell Steve I had a few of his Music videos on my comp, so he told me to get on mIRC and send them. I got a damned firewall message or something. So then I tried AIM. Again, Firewall. anyway this has been a problem for a long time, and I was wondering if anyone knew of any way I could send a damned file to someone, possibly destroying the firewall problem altogether. If anyone has a single damned idea, please. I’d be forever grateful.

Operating System? And how do you connect to the internet?

Of course, that would be useful info, wouldn’t it?

I use DSL to get online, and my OS is

Do you have BlackIce, cuz that’s the only one I’m familiar with.

You might wanna try lowering your firewall’s paranoia setting so it doesn’t block actual good stuff. There might also be checkboxes that allow IRC trading.

Firewalls are a pain in the ass. :too bad;

Originally posted by Valkyrie Esker
[b]Of course, that would be useful info, wouldn’t it?

I use DSL to get online, and my OS is [/b]

…is? Find out on the next episode of “Valkyrie Esker Posts or Edits!”

Well we’re going to need a little more info if you want us to be able to do anything. I’m more than willing to help you with it, I’m usually in the #rpgc channel on the chat server as of 9:30 am (EST), if you want to drop by I’d be happy to give you a hand.

Dear god, if you’re gunna help out DS, Val better bring some supplies to the computer.
While yes, you will no doubt solve her problem, and any other problem that comes about in the next 10 years, Its quite a feat to read through 40k of text :stuck_out_tongue:

Which is why it works much better in the chat, if I post on the message board then there’s usually a few hours in between each post, it makes it needlessly and complicated when you need to wait that long for an answer to a simple question like right-click on such and such and tell mme what’s writen. The best solution to that is trying to think of several possible situations and outligning what to do if that one comes up, that’s why I usually write 4 page posts. However in the chat I’m limited to short paragraphs which makes things much easier to follow.

Whoa, hey darksand, I havent seen you in ages. How ya doin, man? Hey, do you think you could unban me from #rpgc? Piney banned me a while back, cuz some dude came into the #rpgclassics chat and started flaming everyone, then when he was banned, he took it to #rpgc, so me and a couple other people flamed him back, and then I was banned. But I didn’t really say anything that was worth a perm ban. And I need to get some anime, ;_; think you could help?

PS: I gots the same problems yous gots, Val, I can receive files, but I cant send em.

If you’re using Windows XP and its regular firewall, all you have to do is access the connection status screen, choose “properties”, then “advanced” and uncheck the checkbox there to deactivate the firewall. Then you can send the files. However, you’d better get the patch that will protect you against that damn W32. Blast Worm first, or you’ll risk getting it as soon as you turn the firewall off. Having a damn reset countdown popping up without being able to do anything to stop it is rather annoying, so watch out.

Just burn a CD and mail it to him.

Val uses Windows XP Home Edition I believe.

From the Windows Help Files

To enable or disable Internet Connection Firewall

  1. Open Network Connections

  2. Click the Dial-up, LAN or High-Speed Internet connection that you want to protect, and then, under Network Tasks, click Change settings of this connection.

  3. On the Advanced tab, under Internet Connection Firewall, select one of the following:

•To enable Internet Connection Firewall (ICF), select the Protect my computer and network by limiting or preventing access to this computer from the Internet check box.

•To disable Internet Connection Firewall, clear the Protect my computer and network by limiting or preventing access to this computer from the Internet check box.

Originally posted by Ren
Just burn a CD and mail it to him.

Okay, let’s send a CD from canada to Ohio for a fair charge, when the problem can be fixed by just freakin sending it over mIRC/AIM.
God. I swear 8p
Val, I tried helpin, but I couldn’t figure it out. Do you have a router?

Grar, I hate my computer. >< Xelo’s right about my OS, but before I posted it, I accidentally hit Reply, and then it shut down.

Anyway, thanks for the advice, guess, guys.

Does that mean it will work?

What Xelo posted is a solution to the most common problem with being unable to transfer files, the built in firewall in XP has a habit of simply blocking almost everything and in fact 90% of ISPs will tell you to disable it or you might not be able to connect properly.

If however that doesn’t solve your problem then there might be a problem with the way your software firewall is setup (assuming you have one) or it might be with your router (again assuming you have one).

Problems like that aren’t that uncommon, when I first set up my router I could receive files with mIRC, but I couldn’t upload, on the other hand I could upload with ICQ, but not receive files.

Steve: It might work, but, as I’ve said in the past, I’m about as skilled with a computer as I am with using construction equipment, so I have no idea if it will indeed work.

And btw, I live in Canandaigua, NY, not Canada.

Well, you can always give it a try. Until I learned how to disable the firewall, I couldn’t send any files to other people or make uploads. If your firewall is of the same kind as mine, it should be easy to disable.
Just remember to turn it back on after you’re done.

Maybe I should write a guide about this or something. Because there are an awful lot of common misconceptions about why sends via IRC do not go through.

First of all, most likely it is NOT a firewall problem. If you connect to the internet with DSL (or even cable), you are probably behind a router. 99% of routers perform what is called Network Address Translation (NAT). NAT allows more than one user to share a connection even though the router has a single IP address. The problem is that every computer behind the NAT router is invisible to the outside world. All the Internet sees is the router, not what is behind it.

DCC sending requires the receiver of the file to initiate the connection. But to initiate the connection, the receiver must know your IP address – and remember, the outside world cannot see your IP address. The way to get file sending to work is to enable a feature in your router called port forwarding. When the router sees an incoming connection request, it forwards the connection to your computer based on the port number. Problems arise if more than one computer wants to share connections over the same port (for example, two family members both using IRC), but if you’re the only one who needs to enable the port forwarding, you’re okay.

I’ll see if I can drag up some guide on enabling this feature. Oh, and even though I’ve said the problem is not due to a firewall, there still could be a firewall ON TOP of the NAT router. And of course you’ll have to disable that (or open holes in it) after you turn on the port forwarding.